C 컴파일러는 다음을 설치하면 된다.
'GCC'

#yum install -y gcc



C++ 컴파일러는 다음을 설치하면 된다.
'GCC-C++'

설치 결과이다.
# yum install -y gcc-c++
Loaded plugins: fastestmirror
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: centos.mirror.cdnetworks.com
 * extras: centos.mirror.cdnetworks.com
 * updates: centos.mirror.cdnetworks.com
Resolving Dependencies
--> Running transaction check
---> Package gcc-c++.i686 0:4.4.7-17.el6 will be installed
--> Processing Dependency: libstdc++-devel = 4.4.7-17.el6 for package: gcc-c++-4.4.7-17.el6.i686
--> Running transaction check
---> Package libstdc++-devel.i686 0:4.4.7-17.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                 Arch         Version                Repository    Size
================================================================================
Installing:
 gcc-c++                 i686         4.4.7-17.el6           base         4.3 M
Installing for dependencies:
 libstdc++-devel         i686         4.4.7-17.el6           base         1.6 M

Transaction Summary
================================================================================
Install       2 Package(s)

Total download size: 5.9 M
Installed size: 18 M
Downloading Packages:
(1/2): gcc-c++-4.4.7-17.el6.i686.rpm                     | 4.3 MB     00:01
(2/2): libstdc++-devel-4.4.7-17.el6.i686.rpm             | 1.6 MB     00:00
--------------------------------------------------------------------------------
Total                                           2.6 MB/s | 5.9 MB     00:02
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : libstdc++-devel-4.4.7-17.el6.i686                            1/2
  Installing : gcc-c++-4.4.7-17.el6.i686                                    2/2
  Verifying  : libstdc++-devel-4.4.7-17.el6.i686                            1/2
  Verifying  : gcc-c++-4.4.7-17.el6.i686                                    2/2

Installed:
  gcc-c++.i686 0:4.4.7-17.el6

Dependency Installed:
  libstdc++-devel.i686 0:4.4.7-17.el6

Complete!


댓글 작성